{"answers":{"affected":"5 open source packages ship an affected version, including github.com/ipld/go-codec-dagpb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2584 in the wild and no public exploit code.","fix":"Upgrade github.com/ipld/go-codec-dagpb to 1.3.1 or later.","what":"CVE-2022-2584 is a high-severity denial of service vulnerability in github.com/ipld/go-codec-dagpb, published on 27 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2584 and fix it if it is affected.\n\nWhat it is: CVE-2022-2584 is a high-severity denial of service vulnerability in github.com/ipld/go-codec-dagpb, published on 27 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2584 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ipld/go-codec-dagpb (Go): affected all versions; fixed in 1.3.1\n- github.com/ipld/go-codec-dagpb (Go): affected all versions; fixed in 1.3.1\n- github.com/ipld/go-codec-dagpb (Go): affected all versions; fixed in 1.3.1\n- github.com/ipld/go-codec-dagpb (Go): affected all versions; fixed in 1.3.1\n- github.com/ipld/go-codec-dagpb (Go): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2584/ (Markdown: https://insights.sbomify.com/CVE-2022-2584/index.md)","id":"CVE-2022-2584","markdown":"https://insights.sbomify.com/CVE-2022-2584/index.md","name":"CVE-2022-2584","record":{"aliases":["GHSA-967g-cjx4-h7j6","GHSA-g3vv-g2j5-45f2","GO-2022-0422"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go IPLD codec library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing invalid blocks to the dag-pb codec, crashing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Go","cpe":[{"product":"go-codec-dagpb","vendor":"protocol"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The dag-pb codec can panic when decoding invalid blocks.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Panic when decoding invalid blocks in github.com/ipld/go-codec-dagpb","id":"CVE-2022-2584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":5,"n_references":2,"next":{"headline":"Use after free in linux","id":"CVE-2022-2585"},"packages":[{"ecosystem":"Go","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-codec-dagpb","purl":null,"source":"GHSA-967g-cjx4-h7j6"},{"ecosystem":"Go","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-codec-dagpb","purl":"pkg:golang/github.com/ipld/go-codec-dagpb","source":"GHSA-967g-cjx4-h7j6"},{"ecosystem":"Go","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-codec-dagpb","purl":null,"source":"GHSA-g3vv-g2j5-45f2"},{"ecosystem":"Go","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-codec-dagpb","purl":"pkg:golang/github.com/ipld/go-codec-dagpb","source":"GHSA-g3vv-g2j5-45f2"},{"ecosystem":"Go","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-codec-dagpb","purl":"pkg:golang/github.com/ipld/go-codec-dagpb","source":"GO-2022-0422"}],"prev":{"headline":"Race condition in github.com/ntbosscher/gobase","id":"CVE-2022-2583"},"products":["github.com/ipld/go-codec-dagpb"],"published":"2022-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["github.com/ipld/go-codec-dagpb"]},"summary":"An attacker can cause a denial of service by providing invalid blocks to the dag-pb codec, crashing the application.","url":"https://insights.sbomify.com/CVE-2022-2584/"}