{"answers":{"affected":"2 open source packages ship an affected version, including angular. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-25844 in the wild and no public exploit code.","fix":"Product is end of life, replace it.","what":"CVE-2022-25844 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25844 and fix it if it is affected.\n\nWhat it is: CVE-2022-25844 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25844 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular (npm): affected from 1.7.0; no fix listed\n- angular (npm): affected from 1.7.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25844/ (Markdown: https://insights.sbomify.com/CVE-2022-25844/index.md)","id":"CVE-2022-25844","markdown":"https://insights.sbomify.com/CVE-2022-25844/index.md","name":"CVE-2022-25844","record":{"aliases":["CLSA-2026-1774052351","DEBIAN-CVE-2022-25844","GHSA-m2h2-264f-f486","MGASA-2023-0215","MINI-hc56-pmhp-686v","ROOT-APP-NPM-CVE-2022-25844","UBUNTU-CVE-2022-25844"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular JavaScript library","requires_auth":"none","summary":"Attackers can cause denial of service in Angular applications by exploiting a Regular Expression Denial of Service vulnerability in number formatting.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"angularjs","vendor":"angularjs"},{"product":"fedora","vendor":"fedoraproject"},{"product":"ontap_select_deploy_administration_utility","vendor":"netapp"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:F","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-25844","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"fedoraproject:fedora","products":["fedoraproject:fedora","netapp:ontap_select_deploy_administration_utility"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":8,"next":{"headline":"Deserialization of Untrusted Data","id":"CVE-2022-25845"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["1.7.0"],"last_affected":[],"package":"angular","purl":null,"source":"GHSA-m2h2-264f-f486"},{"ecosystem":"npm","fixed":[],"introduced":["1.7.0"],"last_affected":[],"package":"angular","purl":"pkg:npm/angular","source":"GHSA-m2h2-264f-f486"}],"prev":{"headline":"Arbitrary File Write via Archive Extraction (Zip Slip)","id":"CVE-2022-25842"},"products":["angular"],"published":"2022-05-01","related":[{"cvss_score":7.5,"headline":"angular Prototype Pollution vulnerability","id":"CVE-2019-10768","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":7.1,"headline":"AngularJS Cross-site Scripting due to failure to sanitize `xlink.href` attributes","id":"CVE-2019-14863","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":5.4,"headline":"Angular vulnerable to Cross-site Scripting","id":"CVE-2020-7676","kev_date_added":null,"published":"2020-06-08"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the angular.copy() utility","id":"CVE-2023-26116","kev_date_added":null,"published":"2023-03-30"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the $resource service","id":"CVE-2023-26117","kev_date_added":null,"published":"2023-03-30"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the \u003cinput type=\"url\"\u003e element","id":"CVE-2023-26118","kev_date_added":null,"published":"2023-03-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"Attackers can cause denial of service in Angular applications by exploiting a Regular Expression Denial of Service vulnerability in number formatting.","url":"https://insights.sbomify.com/CVE-2022-25844/"}