# CVE-2022-25850: Server-side Request Forgery (SSRF)

> An attacker can exploit SSRF in the proxy mode to leak sensitive server information via untrusted URLs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5hjh-c26m-xw8w, SNYK-GOLANG-GITHUBCOMHOPPSCOTCHPROXYSCOTCH-2435228

## What is CVE-2022-25850?

CVE-2022-25850 is a high-severity server-side request forgery vulnerability in github.com/hoppscotch/proxyscotch, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package github.com/hoppscotch/proxyscotch before 1.0.0 are vulnerable to Server-side Request Forgery (SSRF) when interceptor mode is set to proxy. It occurs when an HTTP request is made by a backend server to an untrusted URL submitted by a user. It leads to a leakage of sensitive information from the server.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-25850?

2 open source packages ship an affected version, including github.com/hoppscotch/proxyscotch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hoppscotch/proxyscotch` | Go | All versions | 1.0.0 |
| `github.com/hoppscotch/proxyscotch` | Go | All versions | 1.0.0 |

Products: Proxyscotch Project Proxyscotch.

## How do I fix CVE-2022-25850?

Upgrade github.com/hoppscotch/proxyscotch to 1.0.0 or later.

## Is CVE-2022-25850 being exploited?

There is no known exploitation of CVE-2022-25850 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25850 and fix it if it is affected.

What it is: CVE-2022-25850 is a high-severity server-side request forgery vulnerability in github.com/hoppscotch/proxyscotch, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25850 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hoppscotch/proxyscotch (Go): affected all versions; fixed in 1.0.0
- github.com/hoppscotch/proxyscotch (Go): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25850/ (Markdown: https://insights.sbomify.com/CVE-2022-25850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25850
- OSV: https://osv.dev/vulnerability/CVE-2022-25850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25850/
Summaries are generated and may contain mistakes; the official description above is the record.
