# CVE-2022-25851: Denial of Service (DoS)

> An attacker can cause a denial of service by providing specific input that triggers an infinite loop in the jpeg-js library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xvf7-4v9q-58w6

## What is CVE-2022-25851?

CVE-2022-25851 is a high-severity denial of service vulnerability in jpeg-js, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package jpeg-js before 0.4.4 are vulnerable to Denial of Service (DoS) where a particular piece of input will cause to enter an infinite loop and never return.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2022-25851?

2 open source packages ship an affected version, including jpeg-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jpeg-js` | npm | All versions | 0.4.4 |
| `jpeg-js` | npm | All versions | 0.4.4 |

Products: Jpeg-Js Project Jpeg-Js.

## How do I fix CVE-2022-25851?

Upgrade jpeg-js to 0.4.4 or later.

## Is CVE-2022-25851 being exploited?

There is no known exploitation of CVE-2022-25851 in the wild and no public exploit code.

## Other vulnerabilities in jpeg-js

- [CVE-2020-8175](https://insights.sbomify.com/CVE-2020-8175/): Uncontrolled resource consumption in jpeg-js (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25851 and fix it if it is affected.

What it is: CVE-2022-25851 is a high-severity denial of service vulnerability in jpeg-js, published on 10 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25851 in the wild and no public exploit code.

Affected packages and fixed versions:
- jpeg-js (npm): affected all versions; fixed in 0.4.4
- jpeg-js (npm): affected all versions; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25851/ (Markdown: https://insights.sbomify.com/CVE-2022-25851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25851
- OSV: https://osv.dev/vulnerability/CVE-2022-25851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25851/
Summaries are generated and may contain mistakes; the official description above is the record.
