# CVE-2022-25852: Denial of Service (DoS)

> Attackers can cause a denial of service in pg-native and libpq by passing non-array arguments that trigger casting failures.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-j32j-2hxv-rqf7

## What is CVE-2022-25852?

CVE-2022-25852 is a high-severity denial of service vulnerability in libpq, published on 17 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package pg-native; all versions of package libpq are vulnerable to Denial of Service (DoS) when the addons attempt to cast the second argument to an array and fail. This happens for every non-array argument passed. **Note:** pg-native is a mere binding to npm's libpq library, which in turn has the addons and bindings to the actual C libpq library. This means that problems found in pg-native may transitively impact npm's libpq.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2022-25852?

4 open source packages ship an affected version, including libpq and pg-native. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpq` | npm | All versions | 1.8.10 |
| `libpq` | npm | All versions | 1.8.10 |
| `pg-native` | npm | All versions | 3.0.1 |
| `pg-native` | npm | All versions | 3.0.1 |

Products: Libpq Project Libpq, Pg-Native Project Pg-Native.

## How do I fix CVE-2022-25852?

Upgrade libpq to 1.8.10 or later.

## Is CVE-2022-25852 being exploited?

There is no known exploitation of CVE-2022-25852 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25852 and fix it if it is affected.

What it is: CVE-2022-25852 is a high-severity denial of service vulnerability in libpq, published on 17 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25852 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpq (npm): affected all versions; fixed in 1.8.10
- libpq (npm): affected all versions; fixed in 1.8.10
- pg-native (npm): affected all versions; fixed in 3.0.1
- pg-native (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25852/ (Markdown: https://insights.sbomify.com/CVE-2022-25852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25852
- OSV: https://osv.dev/vulnerability/CVE-2022-25852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25852/
Summaries are generated and may contain mistakes; the official description above is the record.
