{"answers":{"affected":"2 open source packages ship an affected version, including @yaireo/tagify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25854 in the wild and no public exploit code.","fix":"Upgrade @yaireo/tagify to 4.9.8 or later.","what":"CVE-2022-25854 is a medium-severity cross-site scripting vulnerability in @yaireo/tagify, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25854 and fix it if it is affected.\n\nWhat it is: CVE-2022-25854 is a medium-severity cross-site scripting vulnerability in @yaireo/tagify, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25854 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @yaireo/tagify (npm): affected all versions; fixed in 4.9.8\n- @yaireo/tagify (npm): affected all versions; fixed in 4.9.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25854/ (Markdown: https://insights.sbomify.com/CVE-2022-25854/index.md)","id":"CVE-2022-25854","markdown":"https://insights.sbomify.com/CVE-2022-25854/index.md","name":"CVE-2022-25854","record":{"aliases":["GHSA-pxpf-v376-7xx5","SNYK-JS-YAIREOTAGIFY-2404358"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"An attacker can inject malicious scripts via placeholder values in the @yaireo/tagify UI component, leading to cross-site scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"tagify","vendor":"tagify_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"This affects the package @yaireo/tagify before 4.9.8. The package is used for rendering UI components inside the input or text fields, and an attacker can pass a malicious placeholder value to it to fire the XSS payload.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25854","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":5,"next":{"headline":"create-choo-app3 is vulnerable to Command Injection via the devInstall function","id":"CVE-2022-25855"},"packages":[{"ecosystem":"npm","fixed":["4.9.8"],"introduced":["0"],"last_affected":[],"package":"@yaireo/tagify","purl":null,"source":"GHSA-pxpf-v376-7xx5"},{"ecosystem":"npm","fixed":["4.9.8"],"introduced":["0"],"last_affected":[],"package":"@yaireo/tagify","purl":"pkg:npm/%40yaireo/tagify","source":"GHSA-pxpf-v376-7xx5"}],"prev":{"headline":"semver-tags is vulnerable to Command Injection via the getGitTagsRemote function","id":"CVE-2022-25853"},"products":["@yaireo/tagify"],"published":"2022-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via placeholder values in the @yaireo/tagify UI component, leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2022-25854/"}