# CVE-2022-25854: Cross-site Scripting (XSS)

> An attacker can inject malicious scripts via placeholder values in the @yaireo/tagify UI component, leading to cross-site scripting attacks.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-pxpf-v376-7xx5, SNYK-JS-YAIREOTAGIFY-2404358

## What is CVE-2022-25854?

CVE-2022-25854 is a medium-severity cross-site scripting vulnerability in @yaireo/tagify, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This affects the package @yaireo/tagify before 4.9.8. The package is used for rendering UI components inside the input or text fields, and an attacker can pass a malicious placeholder value to it to fire the XSS payload.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-25854?

2 open source packages ship an affected version, including @yaireo/tagify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@yaireo/tagify` | npm | All versions | 4.9.8 |
| `@yaireo/tagify` | npm | All versions | 4.9.8 |

Products: Tagify Project Tagify.

## How do I fix CVE-2022-25854?

Upgrade @yaireo/tagify to 4.9.8 or later.

## Is CVE-2022-25854 being exploited?

There is no known exploitation of CVE-2022-25854 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25854 and fix it if it is affected.

What it is: CVE-2022-25854 is a medium-severity cross-site scripting vulnerability in @yaireo/tagify, published on 29 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-25854 in the wild and no public exploit code.

Affected packages and fixed versions:
- @yaireo/tagify (npm): affected all versions; fixed in 4.9.8
- @yaireo/tagify (npm): affected all versions; fixed in 4.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25854/ (Markdown: https://insights.sbomify.com/CVE-2022-25854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25854
- OSV: https://osv.dev/vulnerability/CVE-2022-25854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25854/
Summaries are generated and may contain mistakes; the official description above is the record.
