CVE-2022-25857 Denial of Service (DoS)

High 7.5 Published Updated

Attackers can cause denial of service in applications using SnakeYAML by exploiting missing nested depth limitations in collections.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25857?

CVE-2022-25857 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

Weakness: CWE-776

Which versions are affected by CVE-2022-25857?

2 open source packages ship an affected version, including org.yaml:snakeyaml. It affects 2 products.

PackageAffectedFixed in
org.yaml:snakeyaml MavenAll versions1.31
org.yaml:snakeyaml MavenAll versions1.31
Linux distribution packages (8)
prometheus-jmx-exporter AlmaLinux:8All versions0.12.0-8.el8_6
prometheus-jmx-exporter-openjdk11 AlmaLinux:8All versions0.12.0-8.el8_6
prometheus-jmx-exporter Red Hat:enterprise_linux:8::appstreamAll versions0:0.12.0-8.el8_6
prometheus-jmx-exporter-openjdk11 Red Hat:enterprise_linux:8::appstreamAll versions0:0.12.0-8.el8_6
prometheus-jmx-exporter-openjdk17 Red Hat:enterprise_linux:8::appstreamAll versions0:0.12.0-8.el8_6
prometheus-jmx-exporter-openjdk8 Red Hat:enterprise_linux:8::appstreamAll versions0:0.12.0-8.el8_6
prometheus-jmx-exporter Rocky Linux:8All versions0:0.12.0-8.el8
prometheus-jmx-exporter Rocky Linux:8All versions0:0.12.0-8.el8_6

Products include Debian Debian Linux, Snakeyaml Project Snakeyaml.

How do I fix CVE-2022-25857?

Upgrade org.yaml:snakeyaml to 1.31 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-25857 being exploited?

There is no known exploitation of CVE-2022-25857 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALSA-2022:6820, CLEANSTART-2026-QK11051, CLEANSTART-2026-TI64319, CLSA-2026-1786419162, CLSA-2026-1789371790, DEBIAN-CVE-2022-25857 and 7 more.

Is CVE-2022-25857 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free