# CVE-2022-25857: Denial of Service (DoS)

> Attackers can cause denial of service in applications using SnakeYAML by exploiting missing nested depth limitations in collections.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2022
- **Updated:** 16 Sep 2024
- **Also known as:** ALSA-2022:6820, CLEANSTART-2026-QK11051, CLEANSTART-2026-TI64319, CLSA-2026-1786419162, CLSA-2026-1789371790, DEBIAN-CVE-2022-25857, ECHO-8b9e-c30a-1455, GHSA-3mc7-4q67-w48m, MINI-29f4-2pfm-qq4m, RHSA-2022:6820, RLSA-2022:6820, ROOT-APP-MAVEN-CVE-2022-25857, UBUNTU-CVE-2022-25857

## What is CVE-2022-25857?

CVE-2022-25857 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2022-25857?

2 open source packages ship an affected version, including org.yaml:snakeyaml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yaml:snakeyaml` | Maven | All versions | 1.31 |
| `org.yaml:snakeyaml` | Maven | All versions | 1.31 |
| `prometheus-jmx-exporter` | AlmaLinux:8 | All versions | 0.12.0-8.el8_6 |
| `prometheus-jmx-exporter-openjdk11` | AlmaLinux:8 | All versions | 0.12.0-8.el8_6 |
| `prometheus-jmx-exporter` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.12.0-8.el8_6 |
| `prometheus-jmx-exporter-openjdk11` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.12.0-8.el8_6 |
| `prometheus-jmx-exporter-openjdk17` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.12.0-8.el8_6 |
| `prometheus-jmx-exporter-openjdk8` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.12.0-8.el8_6 |
| `prometheus-jmx-exporter` | Rocky Linux:8 | All versions | 0:0.12.0-8.el8 |
| `prometheus-jmx-exporter` | Rocky Linux:8 | All versions | 0:0.12.0-8.el8_6 |

Products: Debian Debian Linux, Snakeyaml Project Snakeyaml.

## How do I fix CVE-2022-25857?

Upgrade org.yaml:snakeyaml to 1.31 or later.

## Is CVE-2022-25857 being exploited?

There is no known exploitation of CVE-2022-25857 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25857 and fix it if it is affected.

What it is: CVE-2022-25857 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25857 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.yaml:snakeyaml (Maven): affected all versions; fixed in 1.31
- org.yaml:snakeyaml (Maven): affected all versions; fixed in 1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25857/ (Markdown: https://insights.sbomify.com/CVE-2022-25857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25857
- OSV: https://osv.dev/vulnerability/CVE-2022-25857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25857/
Summaries are generated and may contain mistakes; the official description above is the record.
