{"answers":{"affected":"4 open source packages ship an affected version, including terser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25858 in the wild and no public exploit code.","fix":"Upgrade terser to a fixed version for your release line: 4.8.1 or 5.14.2.","what":"CVE-2022-25858 is a medium-severity denial of service vulnerability in terser, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25858 and fix it if it is affected.\n\nWhat it is: CVE-2022-25858 is a medium-severity denial of service vulnerability in terser, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- terser (npm): affected all versions; fixed in 4.8.1\n- terser (npm): affected all versions; fixed in 4.8.1\n- terser (npm): affected from 5.0.0; fixed in 5.14.2\n- terser (npm): affected from 5.0.0; fixed in 5.14.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25858/ (Markdown: https://insights.sbomify.com/CVE-2022-25858/index.md)","id":"CVE-2022-25858","markdown":"https://insights.sbomify.com/CVE-2022-25858/index.md","name":"CVE-2022-25858","record":{"aliases":["AZL-44460","AZL-44553","CLSA-2026-1773793047","CLSA-2026-1775089645","CLSA-2026-1775089646","CLSA-2026-1775089649","CLSA-2026-1776645370","CLSA-2026-1779238051","CLSA-2026-1783731813","CLSA-2026-1790950461","DEBIAN-CVE-2022-25858","GHSA-4wf5-vphf-c2xc","ROOT-APP-NPM-CVE-2022-25858","UBUNTU-CVE-2022-25858"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript minifier library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the terser library by providing specially crafted input that triggers inefficient regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"terser","vendor":"terser"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-25858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Remote code execution in simple-git","id":"CVE-2022-25860"},"packages":[{"ecosystem":"npm","fixed":["4.8.1"],"introduced":["0"],"last_affected":[],"package":"terser","purl":null,"source":"GHSA-4wf5-vphf-c2xc"},{"ecosystem":"npm","fixed":["4.8.1"],"introduced":["0"],"last_affected":[],"package":"terser","purl":"pkg:npm/terser","source":"GHSA-4wf5-vphf-c2xc"},{"ecosystem":"npm","fixed":["5.14.2"],"introduced":["5.0.0"],"last_affected":[],"package":"terser","purl":null,"source":"GHSA-4wf5-vphf-c2xc"},{"ecosystem":"npm","fixed":["5.14.2"],"introduced":["5.0.0"],"last_affected":[],"package":"terser","purl":"pkg:npm/terser","source":"GHSA-4wf5-vphf-c2xc"}],"prev":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25857"},"products":["terser"],"published":"2022-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using the terser library by providing specially crafted input that triggers inefficient regular expression processing.","url":"https://insights.sbomify.com/CVE-2022-25858/"}