# CVE-2022-25858: Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in applications using the terser library by providing specially crafted input that triggers inefficient regular expression processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-44460, AZL-44553, CLSA-2026-1773793047, CLSA-2026-1775089645, CLSA-2026-1775089646, CLSA-2026-1775089649, CLSA-2026-1776645370, CLSA-2026-1779238051, CLSA-2026-1783731813, CLSA-2026-1790950461, DEBIAN-CVE-2022-25858, GHSA-4wf5-vphf-c2xc, ROOT-APP-NPM-CVE-2022-25858, UBUNTU-CVE-2022-25858

## What is CVE-2022-25858?

CVE-2022-25858 is a medium-severity denial of service vulnerability in terser, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-25858?

4 open source packages ship an affected version, including terser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `terser` | npm | All versions | 4.8.1 |
| `terser` | npm | All versions | 4.8.1 |
| `terser` | npm | From 5.0.0 | 5.14.2 |
| `terser` | npm | From 5.0.0 | 5.14.2 |

Products: Terser Terser.

## How do I fix CVE-2022-25858?

Upgrade terser to a fixed version for your release line: 4.8.1 or 5.14.2.

## Is CVE-2022-25858 being exploited?

There is no known exploitation of CVE-2022-25858 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25858 and fix it if it is affected.

What it is: CVE-2022-25858 is a medium-severity denial of service vulnerability in terser, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25858 in the wild and no public exploit code.

Affected packages and fixed versions:
- terser (npm): affected all versions; fixed in 4.8.1
- terser (npm): affected all versions; fixed in 4.8.1
- terser (npm): affected from 5.0.0; fixed in 5.14.2
- terser (npm): affected from 5.0.0; fixed in 5.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25858/ (Markdown: https://insights.sbomify.com/CVE-2022-25858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25858
- OSV: https://osv.dev/vulnerability/CVE-2022-25858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25858/
Summaries are generated and may contain mistakes; the official description above is the record.
