{"answers":{"affected":"4 open source packages ship an affected version, including gatsby-plugin-mdx. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25863 in the wild and no public exploit code.","fix":"Upgrade gatsby-plugin-mdx to a fixed version for your release line: 2.14.1 or 3.15.2.","what":"CVE-2022-25863 is a high-severity unsafe deserialization vulnerability in gatsby-plugin-mdx, published on 10 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25863 and fix it if it is affected.\n\nWhat it is: CVE-2022-25863 is a high-severity unsafe deserialization vulnerability in gatsby-plugin-mdx, published on 10 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25863 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gatsby-plugin-mdx (npm): affected all versions; fixed in 2.14.1\n- gatsby-plugin-mdx (npm): affected all versions; fixed in 2.14.1\n- gatsby-plugin-mdx (npm): affected from 3.0.0; fixed in 3.15.2\n- gatsby-plugin-mdx (npm): affected from 3.0.0; fixed in 3.15.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25863/ (Markdown: https://insights.sbomify.com/CVE-2022-25863/index.md)","id":"CVE-2022-25863","markdown":"https://insights.sbomify.com/CVE-2022-25863/index.md","name":"CVE-2022-25863","record":{"aliases":["GHSA-mj46-r4gr-5x83","SNYK-JS-GATSBYPLUGINMDX-2405699"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Gatsby MDX plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code by exploiting unsafe deserialization in the Gatsby MDX plugin when processing untrusted input.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"gatsby-plugin-mdx","vendor":"gatsbyjs"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data","id":"CVE-2022-25863","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"Privilege escalation in Intel(R) oneMKL software","id":"CVE-2022-25864"},"packages":[{"ecosystem":"npm","fixed":["2.14.1"],"introduced":["0"],"last_affected":[],"package":"gatsby-plugin-mdx","purl":null,"source":"GHSA-mj46-r4gr-5x83"},{"ecosystem":"npm","fixed":["2.14.1"],"introduced":["0"],"last_affected":[],"package":"gatsby-plugin-mdx","purl":"pkg:npm/gatsby-plugin-mdx","source":"GHSA-mj46-r4gr-5x83"},{"ecosystem":"npm","fixed":["3.15.2"],"introduced":["3.0.0"],"last_affected":[],"package":"gatsby-plugin-mdx","purl":null,"source":"GHSA-mj46-r4gr-5x83"},{"ecosystem":"npm","fixed":["3.15.2"],"introduced":["3.0.0"],"last_affected":[],"package":"gatsby-plugin-mdx","purl":"pkg:npm/gatsby-plugin-mdx","source":"GHSA-mj46-r4gr-5x83"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2022-25862"},"products":["gatsby-plugin-mdx"],"published":"2022-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by exploiting unsafe deserialization in the Gatsby MDX plugin when processing untrusted input.","url":"https://insights.sbomify.com/CVE-2022-25863/"}