# CVE-2022-25863: Deserialization of Untrusted Data

> Attackers can execute arbitrary code by exploiting unsafe deserialization in the Gatsby MDX plugin when processing untrusted input.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-mj46-r4gr-5x83, SNYK-JS-GATSBYPLUGINMDX-2405699

## What is CVE-2022-25863?

CVE-2022-25863 is a high-severity unsafe deserialization vulnerability in gatsby-plugin-mdx, published on 10 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-25863?

4 open source packages ship an affected version, including gatsby-plugin-mdx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gatsby-plugin-mdx` | npm | All versions | 2.14.1 |
| `gatsby-plugin-mdx` | npm | All versions | 2.14.1 |
| `gatsby-plugin-mdx` | npm | From 3.0.0 | 3.15.2 |
| `gatsby-plugin-mdx` | npm | From 3.0.0 | 3.15.2 |

Products: Gatsbyjs Gatsby-Plugin-Mdx.

## How do I fix CVE-2022-25863?

Upgrade gatsby-plugin-mdx to a fixed version for your release line: 2.14.1 or 3.15.2.

## Is CVE-2022-25863 being exploited?

There is no known exploitation of CVE-2022-25863 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25863 and fix it if it is affected.

What it is: CVE-2022-25863 is a high-severity unsafe deserialization vulnerability in gatsby-plugin-mdx, published on 10 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25863 in the wild and no public exploit code.

Affected packages and fixed versions:
- gatsby-plugin-mdx (npm): affected all versions; fixed in 2.14.1
- gatsby-plugin-mdx (npm): affected all versions; fixed in 2.14.1
- gatsby-plugin-mdx (npm): affected from 3.0.0; fixed in 3.15.2
- gatsby-plugin-mdx (npm): affected from 3.0.0; fixed in 3.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25863/ (Markdown: https://insights.sbomify.com/CVE-2022-25863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25863
- OSV: https://osv.dev/vulnerability/CVE-2022-25863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25863/
Summaries are generated and may contain mistakes; the official description above is the record.
