# CVE-2022-25865: Command Injection


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5875-m6jq-vf78, SNYK-JS-WORKSPACETOOLS-2421201

## What is CVE-2022-25865?

CVE-2022-25865 is a high-severity vulnerability in workspace-tools, published on 13 May 2022. 

### Official description

The package workspace-tools before 0.18.4 are vulnerable to Command Injection via git argument injection. When calling the fetchRemoteBranch(remote: string, remoteBranch: string, cwd: string) function, both the remote and remoteBranch parameters are passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-25865?

2 open source packages ship an affected version, including workspace-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `workspace-tools` | npm | All versions | 0.18.4 |
| `workspace-tools` | npm | All versions | 0.18.4 |

Products: Microsoft Workspace-Tools.

## How do I fix CVE-2022-25865?

Upgrade workspace-tools to 0.18.4 or later.

## Is CVE-2022-25865 being exploited?

There is no known exploitation of CVE-2022-25865 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25865 and fix it if it is affected.

What it is: CVE-2022-25865 is a high-severity vulnerability in workspace-tools, published on 13 May 2022. 
Exploitation: There is no known exploitation of CVE-2022-25865 in the wild and no public exploit code.

Affected packages and fixed versions:
- workspace-tools (npm): affected all versions; fixed in 0.18.4
- workspace-tools (npm): affected all versions; fixed in 0.18.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25865/ (Markdown: https://insights.sbomify.com/CVE-2022-25865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25865
- OSV: https://osv.dev/vulnerability/CVE-2022-25865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25865/
Summaries are generated and may contain mistakes; the official description above is the record.
