{"answers":{"affected":"2 open source packages ship an affected version, including czproject/git-php. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25866 in the wild and no public exploit code.","fix":"Upgrade czproject/git-php to 4.0.3 or later.","what":"CVE-2022-25866 is a high-severity command injection vulnerability in czproject/git-php, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25866 and fix it if it is affected.\n\nWhat it is: CVE-2022-25866 is a high-severity command injection vulnerability in czproject/git-php, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25866 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- czproject/git-php (Packagist): affected all versions; fixed in 4.0.3\n- czproject/git-php (Packagist): affected all versions; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25866/ (Markdown: https://insights.sbomify.com/CVE-2022-25866/index.md)","id":"CVE-2022-25866","markdown":"https://insights.sbomify.com/CVE-2022-25866/index.md","name":"CVE-2022-25866","record":{"aliases":["GHSA-3xpw-vhmv-cw7h","SNYK-PHP-CZPROJECTGITPHP-2421349"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the isRemoteUrlReadable function of the czproject/git-php library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"git-php","vendor":"git-php_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-25866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"NULL Pointer Dereference","id":"CVE-2022-25867"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"czproject/git-php","purl":null,"source":"GHSA-3xpw-vhmv-cw7h"},{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"czproject/git-php","purl":"pkg:composer/czproject/git-php","source":"GHSA-3xpw-vhmv-cw7h"}],"prev":{"headline":"Command Injection","id":"CVE-2022-25865"},"products":["czproject/git-php"],"published":"2022-04-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the isRemoteUrlReadable function of the czproject/git-php library.","url":"https://insights.sbomify.com/CVE-2022-25866/"}