# CVE-2022-25866: Command Injection

> Attackers can execute arbitrary commands via argument injection in the isRemoteUrlReadable function of the czproject/git-php library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3xpw-vhmv-cw7h, SNYK-PHP-CZPROJECTGITPHP-2421349

## What is CVE-2022-25866?

CVE-2022-25866 is a high-severity command injection vulnerability in czproject/git-php, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-25866?

2 open source packages ship an affected version, including czproject/git-php. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `czproject/git-php` | Packagist | All versions | 4.0.3 |
| `czproject/git-php` | Packagist | All versions | 4.0.3 |

Products: Git-Php Project Git-Php.

## How do I fix CVE-2022-25866?

Upgrade czproject/git-php to 4.0.3 or later.

## Is CVE-2022-25866 being exploited?

There is no known exploitation of CVE-2022-25866 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25866 and fix it if it is affected.

What it is: CVE-2022-25866 is a high-severity command injection vulnerability in czproject/git-php, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25866 in the wild and no public exploit code.

Affected packages and fixed versions:
- czproject/git-php (Packagist): affected all versions; fixed in 4.0.3
- czproject/git-php (Packagist): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25866/ (Markdown: https://insights.sbomify.com/CVE-2022-25866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25866
- OSV: https://osv.dev/vulnerability/CVE-2022-25866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25866/
Summaries are generated and may contain mistakes; the official description above is the record.
