CVE-2022-25873 Cross-site Scripting (XSS)

Medium 4.6 Published Updated

Attackers can execute arbitrary scripts via improper input sanitization in the VCalendar component of the Vuetify library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-25873?

CVE-2022-25873 is a medium-severity cross-site scripting vulnerability in vuetify, published on 18 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

Weakness: CWE-79

Which versions are affected by CVE-2022-25873?

4 open source packages ship an affected version, including org.webjars.npm:vuetify and vuetify. It affects 1 product.

PackageAffectedFixed in
org.webjars.npm:vuetify MavenFrom 2.0.0-beta.42.6.10
org.webjars.npm:vuetify MavenFrom 2.0.0-beta.42.6.10
vuetify npmFrom 2.0.0-beta.42.6.10
vuetify npmFrom 2.0.0-beta.42.6.10

Products include Vuetifyjs Vuetify.

How do I fix CVE-2022-25873?

Upgrade org.webjars.npm:vuetify to 2.6.10 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-25873 being exploited?

There is no known exploitation of CVE-2022-25873 in the wild and no public exploit code.

Sources

Also known as GHSA-q4q5-c5cv-2p68.

Is CVE-2022-25873 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free