{"answers":{"affected":"4 open source packages ship an affected version, including org.webjars.npm:vuetify and vuetify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25873 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:vuetify to 2.6.10 or later.","what":"CVE-2022-25873 is a medium-severity cross-site scripting vulnerability in vuetify, published on 18 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-25873 and fix it if it is affected.\n\nWhat it is: CVE-2022-25873 is a medium-severity cross-site scripting vulnerability in vuetify, published on 18 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-25873 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:vuetify (Maven): affected from 2.0.0-beta.4; fixed in 2.6.10\n- org.webjars.npm:vuetify (Maven): affected from 2.0.0-beta.4; fixed in 2.6.10\n- vuetify (npm): affected from 2.0.0-beta.4; fixed in 2.6.10\n- vuetify (npm): affected from 2.0.0-beta.4; fixed in 2.6.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25873/ (Markdown: https://insights.sbomify.com/CVE-2022-25873/index.md)","id":"CVE-2022-25873","markdown":"https://insights.sbomify.com/CVE-2022-25873/index.md","name":"CVE-2022-25873","record":{"aliases":["GHSA-q4q5-c5cv-2p68"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue.js UI library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts via improper input sanitization in the VCalendar component of the Vuetify library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"vuetify","vendor":"vuetifyjs"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.","ecosystems":["Maven","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25873","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":4,"n_references":6,"next":{"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25875"},"packages":[{"ecosystem":"Maven","fixed":["2.6.10"],"introduced":["2.0.0-beta.4"],"last_affected":[],"package":"org.webjars.npm:vuetify","purl":null,"source":"GHSA-q4q5-c5cv-2p68"},{"ecosystem":"Maven","fixed":["2.6.10"],"introduced":["2.0.0-beta.4"],"last_affected":[],"package":"org.webjars.npm:vuetify","purl":"pkg:maven/org.webjars.npm/vuetify","source":"GHSA-q4q5-c5cv-2p68"},{"ecosystem":"npm","fixed":["2.6.10"],"introduced":["2.0.0-beta.4"],"last_affected":[],"package":"vuetify","purl":null,"source":"GHSA-q4q5-c5cv-2p68"},{"ecosystem":"npm","fixed":["2.6.10"],"introduced":["2.0.0-beta.4"],"last_affected":[],"package":"vuetify","purl":"pkg:npm/vuetify","source":"GHSA-q4q5-c5cv-2p68"}],"prev":{"headline":"Out-of-bounds Read","id":"CVE-2022-25872"},"products":["vuetify"],"published":"2022-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via improper input sanitization in the VCalendar component of the Vuetify library.","url":"https://insights.sbomify.com/CVE-2022-25873/"}