# CVE-2022-25875: Cross-site Scripting (XSS)


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-wv8q-r932-8hc7, SNYK-JS-SVELTE-2931080

## What is CVE-2022-25875?

CVE-2022-25875 is a medium-severity vulnerability in svelte, published on 12 Jul 2022. 

### Official description

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-25875?

2 open source packages ship an affected version, including svelte. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `svelte` | npm | All versions | 3.49.0 |
| `svelte` | npm | All versions | 3.49.0 |

Products: Svelte Svelte.

## How do I fix CVE-2022-25875?

Upgrade svelte to 3.49.0 or later.

## Is CVE-2022-25875 being exploited?

There is no known exploitation of CVE-2022-25875 in the wild and no public exploit code.

## Other vulnerabilities in svelte

- [CVE-2021-29261](https://insights.sbomify.com/CVE-2021-29261/): Code injection in n/a (high 7.8)
- [CVE-2026-42567](https://insights.sbomify.com/CVE-2026-42567/): Svelte: ReDoS in `<svelte:element>` Tag Validation (medium 5.9)
- [CVE-2024-45047](https://insights.sbomify.com/CVE-2024-45047/): Potential mXSS vulnerability due to improper HTML escaping in svelte (medium 5.4)
- [CVE-2026-42573](https://insights.sbomify.com/CVE-2026-42573/): Svelte: XSS via DOM Clobbering of Internal Framework State (medium 5.3)
- [CVE-2026-27901](https://insights.sbomify.com/CVE-2026-27901/): Svelte vulnerable to XSS during SSR with contenteditable `bind:innerText` and `bind:textContent` (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25875 and fix it if it is affected.

What it is: CVE-2022-25875 is a medium-severity vulnerability in svelte, published on 12 Jul 2022. 
Exploitation: There is no known exploitation of CVE-2022-25875 in the wild and no public exploit code.

Affected packages and fixed versions:
- svelte (npm): affected all versions; fixed in 3.49.0
- svelte (npm): affected all versions; fixed in 3.49.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25875/ (Markdown: https://insights.sbomify.com/CVE-2022-25875/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25875
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25875
- OSV: https://osv.dev/vulnerability/CVE-2022-25875

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25875/
Summaries are generated and may contain mistakes; the official description above is the record.
