CVE-2022-25885 Denial of Service (DoS)

High 7.5 Published Updated

An attacker can cause a denial of service in applications using the muhammara or hummus libraries by providing invalid data to PDFStreamForResponse.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25885?

CVE-2022-25885 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.

Weakness: CWE-20

Which versions are affected by CVE-2022-25885?

4 open source packages ship an affected version, including hummus and muhammara. It affects 1 product.

PackageAffectedFixed in
hummus npmFrom 1.0.01.0.111
hummus npmFrom 1.0.01.0.111
muhammara npmAll versions2.6.0
muhammara npmAll versions2.6.0

Products include Muhammara Project Muhammara.

How do I fix CVE-2022-25885?

Upgrade hummus to 1.0.111 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-25885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25885 exists.

Sources

Also known as GHSA-frp9-2v6r-gj97.

Is CVE-2022-25885 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free