# CVE-2022-25885: Denial of Service (DoS)

> An attacker can cause a denial of service in applications using the muhammara or hummus libraries by providing invalid data to PDFStreamForResponse.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2022
- **Updated:** 5 May 2025
- **Also known as:** GHSA-frp9-2v6r-gj97

## What is CVE-2022-25885?

CVE-2022-25885 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-25885?

4 open source packages ship an affected version, including hummus and muhammara. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hummus` | npm | From 1.0.0 | 1.0.111 |
| `hummus` | npm | From 1.0.0 | 1.0.111 |
| `muhammara` | npm | All versions | 2.6.0 |
| `muhammara` | npm | All versions | 2.6.0 |

Products: Muhammara Project Muhammara.

## How do I fix CVE-2022-25885?

Upgrade hummus to 1.0.111 or later.

## Is CVE-2022-25885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25885 exists.

## Other vulnerabilities in hummus

- [CVE-2022-25892](https://insights.sbomify.com/CVE-2022-25892/): Denial of Service (DoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25885 and fix it if it is affected.

What it is: CVE-2022-25885 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25885 exists.

Affected packages and fixed versions:
- hummus (npm): affected from 1.0.0; fixed in 1.0.111
- hummus (npm): affected from 1.0.0; fixed in 1.0.111
- muhammara (npm): affected all versions; fixed in 2.6.0
- muhammara (npm): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25885/ (Markdown: https://insights.sbomify.com/CVE-2022-25885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25885
- OSV: https://osv.dev/vulnerability/CVE-2022-25885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25885/
Summaries are generated and may contain mistakes; the official description above is the record.
