{"answers":{"affected":"2 open source packages ship an affected version, including sanitize-html. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25887 in the wild and no public exploit code.","fix":"Upgrade sanitize-html to 2.7.1 or later.","what":"CVE-2022-25887 is a medium-severity denial of service vulnerability in sanitize-html, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25887 and fix it if it is affected.\n\nWhat it is: CVE-2022-25887 is a medium-severity denial of service vulnerability in sanitize-html, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25887 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize-html (npm): affected all versions; fixed in 2.7.1\n- sanitize-html (npm): affected all versions; fixed in 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25887/ (Markdown: https://insights.sbomify.com/CVE-2022-25887/index.md)","id":"CVE-2022-25887","markdown":"https://insights.sbomify.com/CVE-2022-25887/index.md","name":"CVE-2022-25887","record":{"aliases":["CLSA-2026-1776645373","DEBIAN-CVE-2022-25887","GHSA-cgfm-xwp7-2cvr","ROOT-APP-NPM-CVE-2022-25887","UBUNTU-CVE-2022-25887","USN-7464-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML sanitization library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using sanitize-html by exploiting insecure regular expression logic during HTML comment removal.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"sanitize-html","vendor":"apostrophecms"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-25887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25888"},"packages":[{"ecosystem":"npm","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"sanitize-html","purl":null,"source":"GHSA-cgfm-xwp7-2cvr"},{"ecosystem":"npm","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"sanitize-html","purl":"pkg:npm/sanitize-html","source":"GHSA-cgfm-xwp7-2cvr"}],"prev":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25885"},"products":["sanitize-html"],"published":"2022-08-30","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in apostrophecms:sanitize-html","id":"CVE-2014-125128","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":6.1,"headline":"sanitize-html is vulnerable to XSS through incomprehensive sanitization","id":"CVE-2019-25225","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in sanitize-html","id":"CVE-2016-1000237","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":5.3,"headline":"sanitize-html Information Exposure vulnerability","id":"CVE-2024-21501","kev_date_added":null,"published":"2024-02-24"},{"cvss_score":5.3,"headline":"Improper Input Validation in sanitize-html","id":"CVE-2021-26539","kev_date_added":null,"published":"2021-02-08"},{"cvss_score":5.3,"headline":"Improper Input Validation in sanitize-html","id":"CVE-2021-26540","kev_date_added":null,"published":"2021-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using sanitize-html by exploiting insecure regular expression logic during HTML comment removal.","url":"https://insights.sbomify.com/CVE-2022-25887/"}