CVE-2022-25888 Denial of Service (DoS)

High 7.5 Published Updated

An attacker can cause a denial of service by sending unlimited large chunks without closing them, affecting the opcua library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25888?

CVE-2022-25888 is a high-severity denial of service vulnerability in opcua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package opcua from 0.0.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Weakness: CWE-770

Which versions are affected by CVE-2022-25888?

2 open source packages ship an affected version, including opcua. It affects 1 product.

PackageAffectedFixed in
opcua crates.ioAll versions0.11.0
opcua crates.ioAll versions0.11.0

Products include Opcua Project Opcua.

How do I fix CVE-2022-25888?

Upgrade opcua to 0.11.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-25888 being exploited?

There is no known exploitation of CVE-2022-25888 in the wild and no public exploit code.

Sources

Also known as GHSA-8mx2-gqx9-rm7f.

Is CVE-2022-25888 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free