# CVE-2022-25888: Denial of Service (DoS)

> An attacker can cause a denial of service by sending unlimited large chunks without closing them, affecting the opcua library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-8mx2-gqx9-rm7f

## What is CVE-2022-25888?

CVE-2022-25888 is a high-severity denial of service vulnerability in opcua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package opcua from 0.0.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-25888?

2 open source packages ship an affected version, including opcua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opcua` | crates.io | All versions | 0.11.0 |
| `opcua` | crates.io | All versions | 0.11.0 |

Products: Opcua Project Opcua.

## How do I fix CVE-2022-25888?

Upgrade opcua to 0.11.0 or later.

## Is CVE-2022-25888 being exploited?

There is no known exploitation of CVE-2022-25888 in the wild and no public exploit code.

## Other vulnerabilities in opcua

- [CVE-2022-25903](https://insights.sbomify.com/CVE-2022-25903/): Denial of Service (DoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25888 and fix it if it is affected.

What it is: CVE-2022-25888 is a high-severity denial of service vulnerability in opcua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25888 in the wild and no public exploit code.

Affected packages and fixed versions:
- opcua (crates.io): affected all versions; fixed in 0.11.0
- opcua (crates.io): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25888/ (Markdown: https://insights.sbomify.com/CVE-2022-25888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25888
- OSV: https://osv.dev/vulnerability/CVE-2022-25888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25888/
Summaries are generated and may contain mistakes; the official description above is the record.
