# CVE-2022-25891: Denial of Service (DoS)

> An attacker can cause a denial of service in the shoutrrr Go library by sending messages of specific lengths to the PartitionMessage function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2022
- **Updated:** 17 Sep 2024
- **Also known as:** AZL-31969, GHSA-477v-w82m-634j, GO-2022-0528, SNYK-GOLANG-GITHUBCOMCONTAINRRRSHOUTRRRPKGUTIL-2849059

## What is CVE-2022-25891?

CVE-2022-25891 is a high-severity denial of service vulnerability in github.com/containrrr/shoutrrr/pkg/util, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package github.com/containrrr/shoutrrr/pkg/util before 0.6.0 are vulnerable to Denial of Service (DoS) via the util.PartitionMessage function. Exploiting this vulnerability is possible by sending exactly 2000, 4000, or 6000 characters messages.

## Which versions are affected by CVE-2022-25891?

3 open source packages ship an affected version, including github.com/containrrr/shoutrrr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containrrr/shoutrrr` | Go | All versions | 0.6.0 |
| `github.com/containrrr/shoutrrr` | Go | All versions | 0.6.0 |
| `github.com/containrrr/shoutrrr` | Go | All versions | 0.6.0 |

Products: Containrrr Shoutrrr.

## How do I fix CVE-2022-25891?

Upgrade github.com/containrrr/shoutrrr to 0.6.0 or later.

## Is CVE-2022-25891 being exploited?

There is no known exploitation of CVE-2022-25891 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25891 and fix it if it is affected.

What it is: CVE-2022-25891 is a high-severity denial of service vulnerability in github.com/containrrr/shoutrrr/pkg/util, published on 15 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25891 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containrrr/shoutrrr (Go): affected all versions; fixed in 0.6.0
- github.com/containrrr/shoutrrr (Go): affected all versions; fixed in 0.6.0
- github.com/containrrr/shoutrrr (Go): affected all versions; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25891/ (Markdown: https://insights.sbomify.com/CVE-2022-25891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25891
- OSV: https://osv.dev/vulnerability/CVE-2022-25891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25891/
Summaries are generated and may contain mistakes; the official description above is the record.
