CVE-2022-25892 Denial of Service (DoS)
Attackers can cause a denial of service by supplying maliciously crafted PDF files to the muhammara or hummus libraries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-25892?
CVE-2022-25892 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.
Which versions are affected by CVE-2022-25892?
6 open source packages ship an affected version, including hummus and muhammara. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
hummus npm | All versions | 1.0.111 |
hummus npm | All versions | 1.0.111 |
muhammara npm | All versions | 2.6.1 |
muhammara npm | All versions | 2.6.1 |
muhammara npm | From 3.0.0 | 3.1.1 |
muhammara npm | From 3.0.0 | 3.1.1 |
Products include Muhammara Project Muhammara.
How do I fix CVE-2022-25892?
Upgrade hummus to 1.0.111 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-25892 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25892 exists.
Other vulnerabilities in hummus
Sources
Also known as GHSA-9cv5-4wqv-9w94.