{"answers":{"affected":"6 open source packages ship an affected version, including hummus and muhammara. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25892 exists.","fix":"Upgrade hummus to 1.0.111 or later.","what":"CVE-2022-25892 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25892 and fix it if it is affected.\n\nWhat it is: CVE-2022-25892 is a high-severity denial of service vulnerability in hummus, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25892 exists.\n\nAffected packages and fixed versions:\n- hummus (npm): affected all versions; fixed in 1.0.111\n- hummus (npm): affected all versions; fixed in 1.0.111\n- muhammara (npm): affected all versions; fixed in 2.6.1\n- muhammara (npm): affected all versions; fixed in 2.6.1\n- muhammara (npm): affected from 3.0.0; fixed in 3.1.1\n- muhammara (npm): affected from 3.0.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25892/ (Markdown: https://insights.sbomify.com/CVE-2022-25892/index.md)","id":"CVE-2022-25892","markdown":"https://insights.sbomify.com/CVE-2022-25892/index.md","name":"CVE-2022-25892","record":{"aliases":["GHSA-9cv5-4wqv-9w94"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PDF parsing library","requires_auth":"none","summary":"Attackers can cause a denial of service by supplying maliciously crafted PDF files to the muhammara or hummus libraries.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"muhammara","vendor":"muhammara_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-25892","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":6,"n_references":6,"next":{"headline":"Arbitrary Code Execution","id":"CVE-2022-25893"},"packages":[{"ecosystem":"npm","fixed":["1.0.111"],"introduced":["0"],"last_affected":[],"package":"hummus","purl":null,"source":"GHSA-9cv5-4wqv-9w94"},{"ecosystem":"npm","fixed":["1.0.111"],"introduced":["0"],"last_affected":[],"package":"hummus","purl":"pkg:npm/hummus","source":"GHSA-9cv5-4wqv-9w94"},{"ecosystem":"npm","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"muhammara","purl":null,"source":"GHSA-9cv5-4wqv-9w94"},{"ecosystem":"npm","fixed":["2.6.1"],"introduced":["0"],"last_affected":[],"package":"muhammara","purl":"pkg:npm/muhammara","source":"GHSA-9cv5-4wqv-9w94"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"muhammara","purl":null,"source":"GHSA-9cv5-4wqv-9w94"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"muhammara","purl":"pkg:npm/muhammara","source":"GHSA-9cv5-4wqv-9w94"}],"prev":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25891"},"products":["hummus","muhammara"],"published":"2022-11-01","related":[{"cvss_score":7.5,"headline":"Denial of Service (DoS)","id":"CVE-2022-25885","kev_date_added":null,"published":"2022-11-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["n/a"]},"summary":"Attackers can cause a denial of service by supplying maliciously crafted PDF files to the muhammara or hummus libraries.","url":"https://insights.sbomify.com/CVE-2022-25892/"}