# CVE-2022-25896: Session Fixation

> Attackers can hijack user sessions in the Passport authentication library due to improper session regeneration during login and logout events.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1774830278, DEBIAN-CVE-2022-25896, GHSA-v923-w3x8-wh69, ROOT-APP-NPM-CVE-2022-25896, SNYK-JS-PASSPORT-2840631, UBUNTU-CVE-2022-25896

## What is CVE-2022-25896?

CVE-2022-25896 is a medium-severity vulnerability in passport, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2022-25896?

2 open source packages ship an affected version, including passport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passport` | npm | All versions | 0.6.0 |
| `passport` | npm | All versions | 0.6.0 |

Products: Passport Project Passport.

## How do I fix CVE-2022-25896?

Upgrade passport to 0.6.0 or later.

## Is CVE-2022-25896 being exploited?

There is no known exploitation of CVE-2022-25896 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25896 and fix it if it is affected.

What it is: CVE-2022-25896 is a medium-severity vulnerability in passport, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25896 in the wild and no public exploit code.

Affected packages and fixed versions:
- passport (npm): affected all versions; fixed in 0.6.0
- passport (npm): affected all versions; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25896/ (Markdown: https://insights.sbomify.com/CVE-2022-25896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25896
- OSV: https://osv.dev/vulnerability/CVE-2022-25896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25896/
Summaries are generated and may contain mistakes; the official description above is the record.
