CVE-2022-25898 Improper Verification of Cryptographic Signature

High 7.7 Published Updated

Attackers can bypass JWS or JWT signature verification using specially crafted non-Base64URL characters, allowing unauthorized access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25898?

CVE-2022-25898 is a high-severity vulnerability in jsrsasign, published on 1 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The package jsrsasign before 10.5.25 are vulnerable to Improper Verification of Cryptographic Signature when JWS or JWT signature with non Base64URL encoding special characters or number escaped characters may be validated as valid by mistake. Workaround: Validate JWS or JWT signature if it has Base64URL and dot safe string before executing JWS.verify() or JWS.verifyJWT() method.

Weakness: CWE-347

Which versions are affected by CVE-2022-25898?

2 open source packages ship an affected version, including jsrsasign. It affects 1 product.

PackageAffectedFixed in
jsrsasign npmFrom 4.8.010.5.25
jsrsasign npmFrom 4.8.010.5.25

Products include Kjur Jsrsasign.

How do I fix CVE-2022-25898?

Upgrade jsrsasign to 10.5.25 or later.

Is CVE-2022-25898 being exploited?

There is no known exploitation of CVE-2022-25898 in the wild and no public exploit code.

Sources

Also known as GHSA-3fvg-4v2m-98jf.

Is CVE-2022-25898 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free