CVE-2022-25903 Denial of Service (DoS)

High 7.5 Published Updated

Attackers can cause a stack overflow and denial of service by sending deeply nested OPC UA ExtensionObjects or Variants.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-25903?

CVE-2022-25903 is a high-severity denial of service vulnerability in opcua, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package opcua from 0.0.0 are vulnerable to Denial of Service (DoS) via the ExtensionObjects and Variants objects, when it allows unlimited nesting levels, which could result in a stack overflow even if the message size is less than the maximum allowed.

Weakness: CWE-787

Which versions are affected by CVE-2022-25903?

2 open source packages ship an affected version, including opcua. It affects 1 product.

PackageAffectedFixed in
opcua crates.ioAll versions0.11.0
opcua crates.ioAll versions0.11.0

Products include Opcua Project Opcua.

How do I fix CVE-2022-25903?

Upgrade opcua to 0.11.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-25903 being exploited?

There is no known exploitation of CVE-2022-25903 in the wild and no public exploit code.

Sources

Also known as GHSA-hgxq-hcrm-c5pm.

Is CVE-2022-25903 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free