{"answers":{"affected":"2 open source packages ship an affected version, including opcua. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-25903 in the wild and no public exploit code.","fix":"Upgrade opcua to 0.11.0 or later.","what":"CVE-2022-25903 is a high-severity denial of service vulnerability in opcua, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25903 and fix it if it is affected.\n\nWhat it is: CVE-2022-25903 is a high-severity denial of service vulnerability in opcua, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-25903 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opcua (crates.io): affected all versions; fixed in 0.11.0\n- opcua (crates.io): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25903/ (Markdown: https://insights.sbomify.com/CVE-2022-25903/index.md)","id":"CVE-2022-25903","markdown":"https://insights.sbomify.com/CVE-2022-25903/index.md","name":"CVE-2022-25903","record":{"aliases":["GHSA-hgxq-hcrm-c5pm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OPC UA library","requires_auth":"none","summary":"Attackers can cause a stack overflow and denial of service by sending deeply nested OPC UA ExtensionObjects or Variants.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"opcua","vendor":"opcua_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"The package opcua from 0.0.0 are vulnerable to Denial of Service (DoS) via the ExtensionObjects and Variants objects, when it allows unlimited nesting levels, which could result in a stack overflow even if the message size is less than the maximum allowed.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-25903","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Prototype Pollution","id":"CVE-2022-25904"},"packages":[{"ecosystem":"crates.io","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"opcua","purl":null,"source":"GHSA-hgxq-hcrm-c5pm"},{"ecosystem":"crates.io","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"opcua","purl":"pkg:cargo/opcua","source":"GHSA-hgxq-hcrm-c5pm"}],"prev":{"headline":"cookiejar Regular Expression Denial of Service via Cookie.parse function","id":"CVE-2022-25901"},"products":["opcua"],"published":"2022-08-24","related":[{"cvss_score":7.5,"headline":"Denial of Service (DoS)","id":"CVE-2022-25888","kev_date_added":null,"published":"2022-08-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can cause a stack overflow and denial of service by sending deeply nested OPC UA ExtensionObjects or Variants.","url":"https://insights.sbomify.com/CVE-2022-25903/"}