# CVE-2022-25907: Prototype Pollution

> Attackers can pollute JavaScript object prototypes via the merge function, potentially leading to code execution or privilege escalation in applications using ts-deepmerge.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7qqq-gh2f-wq76

## What is CVE-2022-25907?

CVE-2022-25907 is a high-severity vulnerability in ts-deepmerge, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package ts-deepmerge before 2.0.2 are vulnerable to Prototype Pollution due to missing sanitization of the merge function.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-25907?

2 open source packages ship an affected version, including ts-deepmerge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ts-deepmerge` | npm | All versions | 2.0.2 |
| `ts-deepmerge` | npm | All versions | 2.0.2 |

Products: Typescript Deep Merge Project Typescript Deep Merge.

## How do I fix CVE-2022-25907?

Upgrade ts-deepmerge to 2.0.2 or later.

## Is CVE-2022-25907 being exploited?

There is no known exploitation of CVE-2022-25907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25907 and fix it if it is affected.

What it is: CVE-2022-25907 is a high-severity vulnerability in ts-deepmerge, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25907 in the wild and no public exploit code.

Affected packages and fixed versions:
- ts-deepmerge (npm): affected all versions; fixed in 2.0.2
- ts-deepmerge (npm): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25907/ (Markdown: https://insights.sbomify.com/CVE-2022-25907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25907
- OSV: https://osv.dev/vulnerability/CVE-2022-25907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25907/
Summaries are generated and may contain mistakes; the official description above is the record.
