{"answers":{"affected":"2 open source packages ship an affected version, including simple-git. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25912 exists.","fix":"Upgrade simple-git to 3.15.0 or later.","what":"CVE-2022-25912 is a high-severity command injection vulnerability in simple-git, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25912 and fix it if it is affected.\n\nWhat it is: CVE-2022-25912 is a high-severity command injection vulnerability in simple-git, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25912 exists.\n\nAffected packages and fixed versions:\n- simple-git (npm): affected all versions; fixed in 3.15.0\n- simple-git (npm): affected all versions; fixed in 3.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25912/ (Markdown: https://insights.sbomify.com/CVE-2022-25912/index.md)","id":"CVE-2022-25912","markdown":"https://insights.sbomify.com/CVE-2022-25912/index.md","name":"CVE-2022-25912","record":{"aliases":["GHSA-9p95-fxvg-qgq2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js Git library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the clone method if the ext transport protocol is enabled in the simple-git library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"simple-git","vendor":"simple-git_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The package simple-git before 3.15.0 are vulnerable to Remote Code Execution (RCE) when enabling the ext transport protocol, which makes it exploitable via clone() method. This vulnerability exists due to an incomplete fix of [CVE-2022-24066](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2434306).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Remote Code Execution (RCE)","id":"CVE-2022-25912","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":5,"next":{"headline":"Remote Code Execution (RCE)","id":"CVE-2022-25914"},"packages":[{"ecosystem":"npm","fixed":["3.15.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":null,"source":"GHSA-9p95-fxvg-qgq2"},{"ecosystem":"npm","fixed":["3.15.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":"pkg:npm/simple-git","source":"GHSA-9p95-fxvg-qgq2"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-25909"},"products":["simple-git"],"published":"2022-12-12","related":[{"cvss_score":9.8,"headline":"simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE","id":"CVE-2026-28292","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.2,"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":9.2,"headline":"simple-git is vulnerable to Remote Code Execution","id":"CVE-2026-6951","kev_date_added":null,"published":"2026-04-25"},{"cvss_score":8.1,"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.1,"headline":"Remote code execution in simple-git","id":"CVE-2022-25860","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via the clone method if the ext transport protocol is enabled in the simple-git library.","url":"https://insights.sbomify.com/CVE-2022-25912/"}