# CVE-2022-25914: Remote Code Execution (RCE)

> Attackers can execute arbitrary commands via the isDockerInstalled function in the jib-core library, leading to remote code execution.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-936v-cg49-m2g5

## What is CVE-2022-25914?

CVE-2022-25914 is a medium-severity command injection vulnerability in com.google.cloud.tools:jib-core, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package com.google.cloud.tools:jib-core before 0.22.0 are vulnerable to Remote Code Execution (RCE) via the isDockerInstalled function, due to attempting to execute input.

## Which versions are affected by CVE-2022-25914?

2 open source packages ship an affected version, including com.google.cloud.tools:jib-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.google.cloud.tools:jib-core` | Maven | All versions | 0.22.0 |
| `com.google.cloud.tools:jib-core` | Maven | All versions | 0.22.0 |

Products: Jib Project Jib.

## How do I fix CVE-2022-25914?

Upgrade com.google.cloud.tools:jib-core to 0.22.0 or later.

## Is CVE-2022-25914 being exploited?

There is no known exploitation of CVE-2022-25914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25914 and fix it if it is affected.

What it is: CVE-2022-25914 is a medium-severity command injection vulnerability in com.google.cloud.tools:jib-core, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-25914 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.google.cloud.tools:jib-core (Maven): affected all versions; fixed in 0.22.0
- com.google.cloud.tools:jib-core (Maven): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25914/ (Markdown: https://insights.sbomify.com/CVE-2022-25914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25914
- OSV: https://osv.dev/vulnerability/CVE-2022-25914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25914/
Summaries are generated and may contain mistakes; the official description above is the record.
