{"answers":{"affected":"2 open source packages ship an affected version, including mt7688-wiscan. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25916 exists.","fix":"Upgrade mt7688-wiscan to 0.8.3 or later.","what":"CVE-2022-25916 is a high-severity command injection vulnerability in mt7688-wiscan, published on 1 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25916 and fix it if it is affected.\n\nWhat it is: CVE-2022-25916 is a high-severity command injection vulnerability in mt7688-wiscan, published on 1 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25916 exists.\n\nAffected packages and fixed versions:\n- mt7688-wiscan (npm): affected all versions; fixed in 0.8.3\n- mt7688-wiscan (npm): affected all versions; fixed in 0.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25916/ (Markdown: https://insights.sbomify.com/CVE-2022-25916/index.md)","id":"CVE-2022-25916","markdown":"https://insights.sbomify.com/CVE-2022-25916/index.md","name":"CVE-2022-25916","record":{"aliases":["GHSA-5h8c-8ccp-8gmh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm wireless scanning library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via improper input sanitization in the mt7688-wiscan npm package.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"mt7688-wiscan","vendor":"mt7688-wiscan_project"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mt7688-wiscan is vulnerable to Command Injection due to improper input sanitization","id":"CVE-2022-25916","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in Intel(R) Server Board M50CYP Family","id":"CVE-2022-25917"},"packages":[{"ecosystem":"npm","fixed":["0.8.3"],"introduced":["0"],"last_affected":[],"package":"mt7688-wiscan","purl":null,"source":"GHSA-5h8c-8ccp-8gmh"},{"ecosystem":"npm","fixed":["0.8.3"],"introduced":["0"],"last_affected":[],"package":"mt7688-wiscan","purl":"pkg:npm/mt7688-wiscan","source":"GHSA-5h8c-8ccp-8gmh"}],"prev":{"headline":"Auth bypass in ELECOM LAN routers","id":"CVE-2022-25915"},"products":["mt7688-wiscan"],"published":"2023-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via improper input sanitization in the mt7688-wiscan npm package.","url":"https://insights.sbomify.com/CVE-2022-25916/"}