# CVE-2022-25916: mt7688-wiscan is vulnerable to Command Injection due to improper input sanitization

> Attackers can execute arbitrary commands via improper input sanitization in the mt7688-wiscan npm package.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2023
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-5h8c-8ccp-8gmh

## What is CVE-2022-25916?

CVE-2022-25916 is a high-severity command injection vulnerability in mt7688-wiscan, published on 1 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-25916?

2 open source packages ship an affected version, including mt7688-wiscan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mt7688-wiscan` | npm | All versions | 0.8.3 |
| `mt7688-wiscan` | npm | All versions | 0.8.3 |

Products: Mt7688-Wiscan Project Mt7688-Wiscan.

## How do I fix CVE-2022-25916?

Upgrade mt7688-wiscan to 0.8.3 or later.

## Is CVE-2022-25916 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25916 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25916 and fix it if it is affected.

What it is: CVE-2022-25916 is a high-severity command injection vulnerability in mt7688-wiscan, published on 1 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25916 exists.

Affected packages and fixed versions:
- mt7688-wiscan (npm): affected all versions; fixed in 0.8.3
- mt7688-wiscan (npm): affected all versions; fixed in 0.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25916/ (Markdown: https://insights.sbomify.com/CVE-2022-25916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25916
- OSV: https://osv.dev/vulnerability/CVE-2022-25916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25916/
Summaries are generated and may contain mistakes; the official description above is the record.
