# CVE-2022-25923: exec-local-bin vulnerable to Command Injection

> Attackers can execute arbitrary commands via improper input sanitization in the exec-local-bin npm package.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-f259-h6m8-hm8m

## What is CVE-2022-25923?

CVE-2022-25923 is a high-severity command injection vulnerability in exec-local-bin, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package exec-local-bin before 1.2.0 are vulnerable to Command Injection via the theProcess() functionality due to improper user-input sanitization.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-25923?

2 open source packages ship an affected version, including exec-local-bin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exec-local-bin` | npm | All versions | 1.2.0 |
| `exec-local-bin` | npm | All versions | 1.2.0 |

Products: Exec-Local-Bin Project Exec-Local-Bin.

## How do I fix CVE-2022-25923?

Upgrade exec-local-bin to 1.2.0 or later.

## Is CVE-2022-25923 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25923 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25923 and fix it if it is affected.

What it is: CVE-2022-25923 is a high-severity command injection vulnerability in exec-local-bin, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25923 exists.

Affected packages and fixed versions:
- exec-local-bin (npm): affected all versions; fixed in 1.2.0
- exec-local-bin (npm): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25923/ (Markdown: https://insights.sbomify.com/CVE-2022-25923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25923
- OSV: https://osv.dev/vulnerability/CVE-2022-25923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25923/
Summaries are generated and may contain mistakes; the official description above is the record.
