# CVE-2022-25927: ReDoS Vulnerability in ua-parser-js version

> An attacker can cause a denial of service in applications using ua-parser-js by sending specially crafted user agent strings that trigger excessive CPU usage.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2023
- **Updated:** 1 Apr 2025
- **Also known as:** CLSA-2026-1782781179, DEBIAN-CVE-2022-25927, GHSA-fhg7-m89q-25r3, ROOT-APP-NPM-CVE-2022-25927, UBUNTU-CVE-2022-25927

## What is CVE-2022-25927?

CVE-2022-25927 is a medium-severity denial of service vulnerability in ua-parser-js, published on 25 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-25927?

4 open source packages ship an affected version, including ua-parser-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ua-parser-js` | npm | From 0.7.30 | 0.7.33 |
| `ua-parser-js` | npm | From 0.7.30 | 0.7.33 |
| `ua-parser-js` | npm | From 0.8.0 | 1.0.33 |
| `ua-parser-js` | npm | From 0.8.0 | 1.0.33 |

Products: Ua-Parser-Js Project Ua-Parser-Js.

## How do I fix CVE-2022-25927?

Upgrade ua-parser-js to a fixed version for your release line: 0.7.33 or 1.0.33.

## Is CVE-2022-25927 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25927 exists.

Public exploit code:

- https://github.com/masahiro331/cve-2022-25927 (github_poc): https://github.com/masahiro331/cve-2022-25927
- https://github.com/Sleuth-in-town/CVE-2022-25927-test (github_poc): https://github.com/Sleuth-in-town/CVE-2022-25927-test

## Other vulnerabilities in ua-parser-js

- [CVE-2021-27292](https://insights.sbomify.com/CVE-2021-27292/): Regular Expression Denial of Service (ReDoS) in ua-parser-js (high 7.5)
- [CVE-2026-48125](https://insights.sbomify.com/CVE-2026-48125/): UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()` (medium 5.3)
- [CVE-2021-4229](https://insights.sbomify.com/CVE-2021-4229/): ua-parser-js Crypto Mining backdoor (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25927 and fix it if it is affected.

What it is: CVE-2022-25927 is a medium-severity denial of service vulnerability in ua-parser-js, published on 25 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25927 exists.

Affected packages and fixed versions:
- ua-parser-js (npm): affected from 0.7.30; fixed in 0.7.33
- ua-parser-js (npm): affected from 0.7.30; fixed in 0.7.33
- ua-parser-js (npm): affected from 0.8.0; fixed in 1.0.33
- ua-parser-js (npm): affected from 0.8.0; fixed in 1.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25927/ (Markdown: https://insights.sbomify.com/CVE-2022-25927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25927
- OSV: https://osv.dev/vulnerability/CVE-2022-25927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25927/
Summaries are generated and may contain mistakes; the official description above is the record.
