{"answers":{"affected":"2 open source packages ship an affected version, including servst. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25936 exists.","fix":"Upgrade servst to 2.0.3 or later.","what":"CVE-2022-25936 is a high-severity path traversal vulnerability in servst, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25936 and fix it if it is affected.\n\nWhat it is: CVE-2022-25936 is a high-severity path traversal vulnerability in servst, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25936 exists.\n\nAffected packages and fixed versions:\n- servst (npm): affected all versions; fixed in 2.0.3\n- servst (npm): affected all versions; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25936/ (Markdown: https://insights.sbomify.com/CVE-2022-25936/index.md)","id":"CVE-2022-25936","markdown":"https://insights.sbomify.com/CVE-2022-25936/index.md","name":"CVE-2022-25936","record":{"aliases":["GHSA-88v8-v46g-6c9w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js servst library","requires_auth":"none","summary":"An attacker can read arbitrary files from the server due to improper sanitization of file paths in the servst library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"servst","vendor":"servst_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Versions of the package servst before 2.0.3 are vulnerable to Directory Traversal due to improper sanitization of the filePath variable.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Servst vulnerable to Path Traversal","id":"CVE-2022-25936","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Path traversal vulnerability in glance","id":"CVE-2022-25937"},"packages":[{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"servst","purl":null,"source":"GHSA-88v8-v46g-6c9w"},{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"servst","purl":"pkg:npm/servst","source":"GHSA-88v8-v46g-6c9w"}],"prev":{"headline":"Privilege escalation in InRouter302","id":"CVE-2022-25932"},"products":["servst"],"published":"2023-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["n/a"]},"summary":"An attacker can read arbitrary files from the server due to improper sanitization of file paths in the servst library.","url":"https://insights.sbomify.com/CVE-2022-25936/"}