{"answers":{"affected":"2 open source packages ship an affected version, including glance. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25937 exists.","fix":"Upgrade glance to 3.0.9 or later.","what":"CVE-2022-25937 is a medium-severity path traversal vulnerability in glance, published on 13 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25937 and fix it if it is affected.\n\nWhat it is: CVE-2022-25937 is a medium-severity path traversal vulnerability in glance, published on 13 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25937 exists.\n\nAffected packages and fixed versions:\n- glance (npm): affected all versions; fixed in 3.0.9\n- glance (npm): affected all versions; fixed in 3.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25937/ (Markdown: https://insights.sbomify.com/CVE-2022-25937/index.md)","id":"CVE-2022-25937","markdown":"https://insights.sbomify.com/CVE-2022-25937/index.md","name":"CVE-2022-25937","record":{"aliases":["GHSA-3hjh-5hgx-f5wh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js image library","requires_auth":"low_privilege","summary":"An attacker can read files outside the public root directory in the glance Node.js library, potentially exposing sensitive data.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"glance","vendor":"glance_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in [CVE-2018-3715](https://security.snyk.io/vuln/npm:glance:20180129).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path traversal vulnerability in glance","id":"CVE-2022-25937","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of Service (DoS)","id":"CVE-2022-25940"},"packages":[{"ecosystem":"npm","fixed":["3.0.9"],"introduced":["0"],"last_affected":[],"package":"glance","purl":null,"source":"GHSA-3hjh-5hgx-f5wh"},{"ecosystem":"npm","fixed":["3.0.9"],"introduced":["0"],"last_affected":[],"package":"glance","purl":"pkg:npm/glance","source":"GHSA-3hjh-5hgx-f5wh"}],"prev":{"headline":"Servst vulnerable to Path Traversal","id":"CVE-2022-25936"},"products":["glance"],"published":"2023-02-13","related":[{"cvss_score":9.3,"headline":"Path traversal in n/a","id":"CVE-2022-31546","kev_date_added":null,"published":"2022-07-11"},{"cvss_score":6.5,"headline":"Path Traversal in glance","id":"CVE-2018-3715","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in glance","id":"CVE-2018-3748","kev_date_added":null,"published":"2018-07-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["n/a"]},"summary":"An attacker can read files outside the public root directory in the glance Node.js library, potentially exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2022-25937/"}