# CVE-2022-25937: Path traversal vulnerability in glance

> An attacker can read files outside the public root directory in the glance Node.js library, potentially exposing sensitive data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2023
- **Updated:** 21 Mar 2025
- **Also known as:** GHSA-3hjh-5hgx-f5wh

## What is CVE-2022-25937?

CVE-2022-25937 is a medium-severity path traversal vulnerability in glance, published on 13 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in [CVE-2018-3715](https://security.snyk.io/vuln/npm:glance:20180129).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-25937?

2 open source packages ship an affected version, including glance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | npm | All versions | 3.0.9 |
| `glance` | npm | All versions | 3.0.9 |

Products: Glance Project Glance.

## How do I fix CVE-2022-25937?

Upgrade glance to 3.0.9 or later.

## Is CVE-2022-25937 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25937 exists.

## Other vulnerabilities in glance

- [CVE-2022-31546](https://insights.sbomify.com/CVE-2022-31546/): Path traversal in n/a (critical 9.3)
- [CVE-2018-3715](https://insights.sbomify.com/CVE-2018-3715/): Path Traversal in glance (medium 6.5)
- [CVE-2018-3748](https://insights.sbomify.com/CVE-2018-3748/): Cross-Site Scripting in glance (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25937 and fix it if it is affected.

What it is: CVE-2022-25937 is a medium-severity path traversal vulnerability in glance, published on 13 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25937 exists.

Affected packages and fixed versions:
- glance (npm): affected all versions; fixed in 3.0.9
- glance (npm): affected all versions; fixed in 3.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25937/ (Markdown: https://insights.sbomify.com/CVE-2022-25937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25937
- OSV: https://osv.dev/vulnerability/CVE-2022-25937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25937/
Summaries are generated and may contain mistakes; the official description above is the record.
