# CVE-2022-2596: Inefficient Regular Expression Complexity in node-fetch/node-fetch

> Attackers can cause denial of service in applications using node-fetch by triggering inefficient regular expression complexity.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 7 Oct 2026
- **Also known as:** GHSA-vp56-6g26-6827, UBUNTU-CVE-2022-2596

## What is CVE-2022-2596?

CVE-2022-2596 is a medium-severity denial of service vulnerability in node-fetch/node-fetch, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inefficient Regular Expression Complexity in GitHub repository node-fetch/node-fetch prior to 3.2.10.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-2596?

2 open source packages ship an affected version, including node-fetch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-fetch` | npm | From 3.0.0 | 3.2.10 |
| `node-fetch` | npm | From 3.0.0 | 3.2.10 |

Products: Node-Fetch Project Node-Fetch.

## How do I fix CVE-2022-2596?

Upgrade node-fetch to 3.2.10 or later.

## Is CVE-2022-2596 being exploited?

There is no known exploitation of CVE-2022-2596 in the wild and no public exploit code.

## Other vulnerabilities in node-fetch/node-fetch

- [CVE-2020-15168](https://insights.sbomify.com/CVE-2020-15168/): File size limit bypass in node-fetch (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2596 and fix it if it is affected.

What it is: CVE-2022-2596 is a medium-severity denial of service vulnerability in node-fetch/node-fetch, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2596 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-fetch (npm): affected from 3.0.0; fixed in 3.2.10
- node-fetch (npm): affected from 3.0.0; fixed in 3.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2596/ (Markdown: https://insights.sbomify.com/CVE-2022-2596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2596
- OSV: https://osv.dev/vulnerability/CVE-2022-2596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2596/
Summaries are generated and may contain mistakes; the official description above is the record.
