{"answers":{"affected":"2 open source packages ship an affected version, including eta. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25967 exists.","fix":"Upgrade eta to 2.0.0 or later.","what":"CVE-2022-25967 is a high-severity code injection vulnerability in eta, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-25967 and fix it if it is affected.\n\nWhat it is: CVE-2022-25967 is a high-severity code injection vulnerability in eta, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25967 exists.\n\nAffected packages and fixed versions:\n- eta (npm): affected all versions; fixed in 2.0.0\n- eta (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-25967/ (Markdown: https://insights.sbomify.com/CVE-2022-25967/index.md)","id":"CVE-2022-25967","markdown":"https://insights.sbomify.com/CVE-2022-25967/index.md","name":"CVE-2022-25967","record":{"aliases":["GHSA-mf6x-hrgr-658f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript template engine","requires_auth":"none","summary":"Attackers can execute arbitrary code by overwriting template configuration via user-defined data in Express render API calls.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"eta","vendor":"eta.js"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API.\r\r**Note:** This is exploitable only for users who are rendering templates with user-defined data.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Eta vulnerable to Code Injection via templates rendered with user-defined data","id":"CVE-2022-25967","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"This candidate was in a CNA pool that was not assigned to any issues during 2022.","id":"CVE-2022-25968"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"eta","purl":null,"source":"GHSA-mf6x-hrgr-658f"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"eta","purl":"pkg:npm/eta","source":"GHSA-mf6x-hrgr-658f"}],"prev":{"headline":"Privilege escalation in Intel(R) Edge Insights for Industrial software","id":"CVE-2022-25966"},"products":["eta"],"published":"2023-01-30","related":[{"cvss_score":8.6,"headline":"Cross-site (XSS) vulnerability with Express API in Eta","id":"CVE-2023-23630","kev_date_added":null,"published":"2023-02-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by overwriting template configuration via user-defined data in Express render API calls.","url":"https://insights.sbomify.com/CVE-2022-25967/"}