# CVE-2022-25967: Eta vulnerable to Code Injection via templates rendered with user-defined data

> Attackers can execute arbitrary code by overwriting template configuration via user-defined data in Express render API calls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2023
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-mf6x-hrgr-658f

## What is CVE-2022-25967?

CVE-2022-25967 is a high-severity code injection vulnerability in eta, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API.**Note:** This is exploitable only for users who are rendering templates with user-defined data.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-25967?

2 open source packages ship an affected version, including eta. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eta` | npm | All versions | 2.0.0 |
| `eta` | npm | All versions | 2.0.0 |

Products: Eta.js Eta.

## How do I fix CVE-2022-25967?

Upgrade eta to 2.0.0 or later.

## Is CVE-2022-25967 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25967 exists.

## Other vulnerabilities in eta

- [CVE-2023-23630](https://insights.sbomify.com/CVE-2023-23630/): Cross-site (XSS) vulnerability with Express API in Eta (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-25967 and fix it if it is affected.

What it is: CVE-2022-25967 is a high-severity code injection vulnerability in eta, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-25967 exists.

Affected packages and fixed versions:
- eta (npm): affected all versions; fixed in 2.0.0
- eta (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-25967/ (Markdown: https://insights.sbomify.com/CVE-2022-25967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-25967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-25967
- OSV: https://osv.dev/vulnerability/CVE-2022-25967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-25967/
Summaries are generated and may contain mistakes; the official description above is the record.
