# CVE-2022-26184: Poetry before v1.1.9 contains Untrusted Search Path

> Attackers can execute arbitrary code by placing malicious files in a directory where users run Poetry commands on Windows.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xr2c-5w89-63pv, PYSEC-2022-234, UBUNTU-CVE-2022-26184

## What is CVE-2022-26184?

CVE-2022-26184 is a critical path traversal vulnerability in n/a, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Poetry v1.1.9 and below was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2022-26184?

3 open source packages ship an affected version, including poetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |

Products: Python-Poetry Poetry.

## How do I fix CVE-2022-26184?

Upgrade poetry to 1.1.9 or later.

## Is CVE-2022-26184 being exploited?

There is no known exploitation of CVE-2022-26184 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36069](https://insights.sbomify.com/CVE-2022-36069/): Poetry Argument Injection vulnerability can lead to local Code Execution (high 7.3)
- [CVE-2022-36070](https://insights.sbomify.com/CVE-2022-36070/): Poetry's Untrusted Search Path can lead to Local Code Execution on Windows (high 7.3)
- [CVE-2026-34591](https://insights.sbomify.com/CVE-2026-34591/): Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26184 and fix it if it is affected.

What it is: CVE-2022-26184 is a critical path traversal vulnerability in n/a, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26184 in the wild and no public exploit code.

Affected packages and fixed versions:
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26184/ (Markdown: https://insights.sbomify.com/CVE-2022-26184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26184
- OSV: https://osv.dev/vulnerability/CVE-2022-26184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26184/
Summaries are generated and may contain mistakes; the official description above is the record.
