# CVE-2022-26260: Prototype Pollution in simple-plist

> Prototype pollution in Simple-Plist allows attackers to inject properties into Object.prototype, potentially leading to remote code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gff7-g5r8-mg8m

## What is CVE-2022-26260?

CVE-2022-26260 is a critical code injection vulnerability in n/a, published on 22 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Simple-Plist v1.3.0 was discovered to contain a prototype pollution vulnerability via .parse().

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-26260?

2 open source packages ship an affected version, including simple-plist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-plist` | npm | All versions | 1.3.1 |
| `simple-plist` | npm | All versions | 1.3.1 |

Products: Simple-Plist Project Simple-Plist.

## How do I fix CVE-2022-26260?

Upgrade simple-plist to 1.3.1 or later.

## Is CVE-2022-26260 being exploited?

There is no known exploitation of CVE-2022-26260 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26260 and fix it if it is affected.

What it is: CVE-2022-26260 is a critical code injection vulnerability in n/a, published on 22 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26260 in the wild and no public exploit code.

Affected packages and fixed versions:
- simple-plist (npm): affected all versions; fixed in 1.3.1
- simple-plist (npm): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26260/ (Markdown: https://insights.sbomify.com/CVE-2022-26260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26260
- OSV: https://osv.dev/vulnerability/CVE-2022-26260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26260/
Summaries are generated and may contain mistakes; the official description above is the record.
