CVE-2022-2630 Information disclosure in GitLab
Improper access control in GitLab allows attackers to disclose confidential information via Incident timeline events.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2630?
CVE-2022-2630 is a medium-severity vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An improper access control issue in GitLab CE/EE affecting all versions starting from 15.2 before 15.2.4, all versions from 15.3 before 15.3.2 allows disclosure of confidential information via the Incident timeline events.
Weakness: CWE-284
Which versions are affected by CVE-2022-2630?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.2.0 | 15.2.4, 15.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2630?
Upgrade gitlab to a fixed version for your release line: 15.2.4 or 15.3.2.
Is CVE-2022-2630 being exploited?
There is no known exploitation of CVE-2022-2630 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2630, GHSA-wccp-g34r-cx74, UBUNTU-CVE-2022-2630.