# CVE-2022-26336: A carefully crafted TNEF file can cause an out of memory exception

> Attackers can cause an out-of-memory denial of service by supplying crafted TNEF files to applications using the Apache POI scratchpad library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1780534250, GHSA-mqvp-7rrg-9jxc, UBUNTU-CVE-2022-26336

## What is CVE-2022-26336?

CVE-2022-26336 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 4 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A shortcoming in the HMEF package of poi-scratchpad (Apache POI) allows an attacker to cause an Out of Memory exception. This package is used to read TNEF files (Microsoft Outlook and Microsoft Exchange Server). If an application uses poi-scratchpad to parse TNEF files and the application allows untrusted users to supply them, then a carefully crafted file can cause an Out of Memory exception. This issue affects poi-scratchpad version 5.2.0 and prior versions. Users are recommended to upgrade to poi-scratchpad 5.2.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-26336?

2 open source packages ship an affected version, including org.apache.poi:poi-scratchpad. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.poi:poi-scratchpad` | Maven | From 3.8-beta1 | 5.2.1 |
| `org.apache.poi:poi-scratchpad` | Maven | From 3.8-beta1 | 5.2.1 |

Products: Apache Poi, Netapp Active Iq Unified Manager.

## How do I fix CVE-2022-26336?

Upgrade org.apache.poi:poi-scratchpad to 5.2.1 or later.

## Is CVE-2022-26336 being exploited?

There is no known exploitation of CVE-2022-26336 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2017-12626](https://insights.sbomify.com/CVE-2017-12626/): Denial of Service in Apache POI (high 7.5)
- [CVE-2019-12415](https://insights.sbomify.com/CVE-2019-12415/): Improper Restriction of XML External Entity Reference in Apache POI (medium 5.5)
- [CVE-2017-5644](https://insights.sbomify.com/CVE-2017-5644/): Improper Restriction of Recursive Entity References in DTDs in Apache POI (medium 5.5)
- [CVE-2016-5000](https://insights.sbomify.com/CVE-2016-5000/): Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability (medium 5.5)
- [CVE-2025-31672](https://insights.sbomify.com/CVE-2025-31672/): Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26336 and fix it if it is affected.

What it is: CVE-2022-26336 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 4 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-26336 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.poi:poi-scratchpad (Maven): affected from 3.8-beta1; fixed in 5.2.1
- org.apache.poi:poi-scratchpad (Maven): affected from 3.8-beta1; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26336/ (Markdown: https://insights.sbomify.com/CVE-2022-26336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26336
- OSV: https://osv.dev/vulnerability/CVE-2022-26336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26336/
Summaries are generated and may contain mistakes; the official description above is the record.
