# CVE-2022-26488: Privilege escalation in n/a

> Local attackers can hijack the system search path to execute arbitrary code with elevated privileges if Python is installed for all users with PATH enabled.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 14 Oct 2026
- **Also known as:** BIT-libpython-2022-26488, BIT-python-2022-26488, BIT-python-min-2022-26488, GHSA-3f7p-x3g9-9grh

## What is CVE-2022-26488?

CVE-2022-26488 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 7 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Python before 3.10.3 on Windows, local users can gain privileges because the search path is inadequately secured. The installer may allow a local attacker to add user-writable directories to the system search path. To exploit, an administrator must have installed Python for all users and enabled PATH entries. A non-administrative user can trigger a repair that incorrectly adds user-writable paths into PATH, enabling search-path hijacking of other users and system services. This affects Python (CPython) through 3.7.12, 3.8.x through 3.8.12, 3.9.x through 3.9.10, and 3.10.x through 3.10.2.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2022-26488?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.7.13, 3.10.3, 3.8.13, 3.9.11 |
| `python` | Bitnami | All versions | 3.7.13, 3.10.3, 3.8.13, 3.9.11 |
| `python-min` | Bitnami | All versions | 3.7.13, 3.10.3, 3.8.13, 3.9.11 |

Products: Netapp Active Iq Unified Manager, Netapp Ontap Select Deploy Administration Utility, Python Python.

## How do I fix CVE-2022-26488?

Upgrade libpython to a fixed version for your release line: 3.7.13, 3.10.3, 3.8.13 or 3.9.11.

## Is CVE-2022-26488 being exploited?

There is no known exploitation of CVE-2022-26488 in the wild and no public exploit code.

Public exploit code:

- POC Exploit for CVE-2022-26488 - Python for Windows (CPython) escalation of privilege vulnerability, discovered by the Lockheed Martin Red Team. (github_poc): https://github.com/techspence/PyPATHPwner

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26488 and fix it if it is affected.

What it is: CVE-2022-26488 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 7 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26488 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.7.13, 3.10.3, 3.8.13, 3.9.11
- python (Bitnami): affected all versions; fixed in 3.7.13, 3.10.3, 3.8.13, 3.9.11
- python-min (Bitnami): affected all versions; fixed in 3.7.13, 3.10.3, 3.8.13, 3.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26488/ (Markdown: https://insights.sbomify.com/CVE-2022-26488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26488
- OSV: https://osv.dev/vulnerability/CVE-2022-26488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26488/
Summaries are generated and may contain mistakes; the official description above is the record.
