# CVE-2022-26520: pgjdbc Arbitrary File Write Vulnerability

> An attacker controlling JDBC connection properties can write arbitrary files, potentially leading to remote code execution via web shell creation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-postgresql-jdbc-driver-2022-26520, CLEANSTART-2026-DT34494, CLEANSTART-2026-NM72661, DEBIAN-CVE-2022-26520, GHSA-673j-qm5f-xpv8, GHSA-727h-hrw8-jg8q, SUSE-FU-2022:2794-1, SUSE-SU-2022:2655-1, openSUSE-SU-2024:12126-1

## What is CVE-2022-26520?

CVE-2022-26520 is a critical path traversal vulnerability in Debian Debian Linux, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In pgjdbc before 42.3.3, an attacker (who controls the jdbc URL or properties) can call java.util.logging.FileHandler to write to arbitrary files through the loggerFile and loggerLevel connection properties. An example situation is that an attacker could create an executable JSP file under a Tomcat web root. NOTE: the vendor's position is that there is no pgjdbc vulnerability; instead, it is a vulnerability for any application to use the pgjdbc driver with untrusted connection properties

## Which versions are affected by CVE-2022-26520?

5 open source packages ship an affected version, including org.postgresql:postgresql and postgresql-jdbc-driver. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.postgresql:postgresql` | Maven | From 42.1.0 | 42.3.3 |
| `org.postgresql:postgresql` | Maven | From 42.1.0 | 42.3.3 |
| `org.postgresql:postgresql` | Maven | From 42.1.0 | 42.3.3 |
| `org.postgresql:postgresql` | Maven | From 42.1.0 | 42.3.3 |
| `postgresql-jdbc-driver` | Bitnami | From 42.1.0 | 42.1.5, 42.3.3 |
| `ongres-scram` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 2.1-150300.3.3.4 |
| `ongres-stringprep` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 1.1-150300.7.3.4 |
| `postgresql-jdbc` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 42.2.25-150300.3.5.2 |
| `postgresql-jdbc` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 42.2.25-150400.3.3.2 |
| `ongres-scram` | SUSE:Manager Server Module 4.2 | All versions | 2.1-150300.3.3.4 |
| `ongres-stringprep` | SUSE:Manager Server Module 4.2 | All versions | 1.1-150300.7.3.4 |
| `postgresql-jdbc` | SUSE:Manager Server Module 4.2 | All versions | 42.2.25-150300.3.5.2 |
| `ongres-scram` | openSUSE:Leap 15.3 | All versions | 2.1-150300.3.3.4 |
| `ongres-stringprep` | openSUSE:Leap 15.3 | All versions | 1.1-150300.7.3.4 |
| `postgresql-jdbc` | openSUSE:Leap 15.3 | All versions | 42.2.25-150300.3.5.2 |
| `postgresql-jdbc` | openSUSE:Leap 15.4 | All versions | 42.2.25-150400.3.3.2 |

Products: Debian Debian Linux, Postgresql Postgresql Jdbc Driver.

## How do I fix CVE-2022-26520?

Upgrade org.postgresql:postgresql to 42.3.3 or later.

## Is CVE-2022-26520 being exploited?

There is no known exploitation of CVE-2022-26520 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-26520 and fix it if it is affected.

What it is: CVE-2022-26520 is a critical path traversal vulnerability in Debian Debian Linux, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-26520 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.postgresql:postgresql (Maven): affected from 42.1.0; fixed in 42.3.3
- org.postgresql:postgresql (Maven): affected from 42.1.0; fixed in 42.3.3
- org.postgresql:postgresql (Maven): affected from 42.1.0; fixed in 42.3.3
- org.postgresql:postgresql (Maven): affected from 42.1.0; fixed in 42.3.3
- postgresql-jdbc-driver (Bitnami): affected from 42.1.0; fixed in 42.1.5, 42.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-26520/ (Markdown: https://insights.sbomify.com/CVE-2022-26520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-26520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-26520
- OSV: https://osv.dev/vulnerability/CVE-2022-26520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-26520/
Summaries are generated and may contain mistakes; the official description above is the record.
